VMware vSphere 6.5 OVF Package Compressed Disks Not Supported OVF Import

 

Update: RP4VMs_rel5.0.SP1 now supports vSphere & vCenter 6.5 .

Issue:

While trying to import an OVA, EMC Recover Point for VM 5 to be specific, I faced the following issue knowing that I recently upgraded my lab to vCenter/vSphere 6.5 and received the following error:

“ OVF Package with compressed disks is currently not supported for OVF import “.

I tried this on my nested vSphere 6.0 and seemed to work fine thus the issue lies with the newly updated vSphere 6.5 . First thing I did was un-RARing the OVA and trying to import the files independently which also failed with the same error.

Time to Google Smile , Nothing interesting found, Fine lets have a look at the release notes, found it :

image

Solution:

1- Download VMware Open Virtualization Format Tool 4.0.0 .

2- Install the tool on the machine that has the OVA stored. Its just next, next, finish Smile .

image

3- For the sake of simplicity copy the OVA file to the VMware tool install directory and open a command prompt.

image

4- Run the following command and replace the “ OVA.ova” with your OVA file name and the “new-OVA” with the new name of the uncompressed OVA file to be generated which will be used to import:

“ ovftool.exe OVA.ova newOVA.ova “

image

5- Now go to vCenter and import the newly created OVA file, it should work fine, if you get the below listed error then extract the new OVA file using WinRAR and delete the manifest file .mf and re-import using the extracted files which should not include the manifest file:

image

image

image

image

6- IF and Only IF by any chance you are trying to import EMC Recover Point for VMs 5.0 , you will get another error while trying to import which relates to a corrupt configuration file, to resolve the issue we need to delete line 282 from the OVF configuration file:

  • UnRAR the newly created OVA files.
  • Delete the Manifest file.
  • Edit the .ovf configuration file using Notepad++ .
  • Delete line 282 and save.
  • Re-import into vCenter.

image

image

image

image

That’s about it never the less EMC RecoverPoint for VMs 5.0 cluster installation failed as the VIBS are not yet supported on vSphere 6.5 Sad smile ….

Salam Smile.

21452 Total Views 114 Views Today

10 thoughts

  1. That’s correct, RP4VMs 5.0 doesn’t support vSphere 6.5 yet, it is due soon. Stay tuned for more info…

    1. Cant wait 🙂 . BTW any clue if RP4VMs 5.0 is going to be supported for VxRail 4.0, well technically its still vSphere 6.0 u2 with VSAN but licensing wise is the free 15 VMs going to be strictly RP4VMs 4.3.x or 5.0 can be used !?

      Thanks.

      1. I can confirm that RP4VMs 5.0 licenses are provided with VxRail 4.0 . As for RP4VM 5.0 being supported on vSphere 6.5, still no news from Dell EMC.

  2. In such case, you can use the fat client (v6), directly connected to the ESXi (v6.5), and it works (since the v6 fat client supports compressed disks).

Leave a Reply

Your email address will not be published. Required fields are marked *